🔄 Losowy artykuł
Szlaki górskie Pociągiem dookoła Polski Podróże kulinarne Hotele-unikaty świata Parkingi przy lotniskach Łowiska Europy Campingi dla kamperów Imprezy — atrakcje w Polsce Poradnik pilota drona Wydarzenia i bilety Promocje bankowe Kamery na żywo Oferty Centrum Podróży Koliber Triper.pl Trip.FazaFM.com — plany podróży

Point-to-Point Protocol

Protokół PPP.

Point-to-Point Protocol (PPP), protokół połączenia punkt-punkt, – protokół komunikacyjny warstwy łącza danych używany przy bezpośrednich połączeniach pomiędzy dwoma węzłami sieci[1]. PPP może być również skonfigurowany na interfejsie szeregowym asynchronicznym i synchronicznym. Służy również do prostego zestawiania tuneli. PPP jest stosowany w technologii WAN[1]. Z protokołem tym wiąże się uwierzytelnianie PAP lub CHAP.

Zazwyczaj występuje w dwóch odmianach: PPPoE oraz PPPoA w zależności od zastosowanego kapsułkowania.

PPP tworzy dwie podwarstwy w warstwie łącza danych w modelu OSI: Link Control Protocol i Network Control Protocol. Do pierwszej podwarstwy można zaliczyć autoryzację, a druga odpowiada za komunikację z warstwą sieciową[1].

W komunikacji z wykorzystaniem protokołu IP PPP zastąpił starszy (i prostszy) protokół SLIP[1].

Rozszerzona detekcja błędów

PPP wykorzystuje pola Frame Check Sequence (FCS), aby wykryć błędy powstałe w ramkach podczas transmisji. Gdy liczba nieprawidłowych przekazów nadmiernie wzrośnie, łącze może ulec zerwaniu.

Dodatkowe opcje PPP

Protokół sterowania łączem (ang. link control protocol, LCP) jest integralną częścią PPP zdefiniowaną w RFC i zawiera wykrywanie zapętlonych połączeń. Opiera się to na wykorzystywaniu liczby magicznej (ang. magic number). Każdy z uczestników komunikacji wysyła komunikaty LCP zawierające różniące się liczby. Jeżeli pojawi się połączenie zapętlone, to odbiornik dostanie wysłaną przez siebie wartość. W ten sposób może to wykryć. Częścią specyfikacji PPP jest również protokół Internet Protocol Control Protocol (IPCP), który pozwala na automatyczne określenie adresów IP lokalnego komputera oraz zdalnej maszyny. Dodatkowo często wykorzystuje się DHCP do przekazywania adresu IP serwera DNS.

Format ramek PPP[1]

Nazwa Ilość bajtów Opis
Flaga 1 oznacza początek lub koniec ramki
Adres 1 adres rozgłoszeniowy
Kontrola 1 bajt kontrolny
Protokół 2 określa protokół w polu danych
Dane zmienna (od 0) zawiera datagram
FCS 2 (rzadziej 4) suma kontrolna, kontrola błędów

RFC

Protokół PPP został opisany przez IETF w specyfikacji RFC 1661 ↓.

RFC 1994 ↓ opisuje protokół Challenge Handshake Authentication Protocol (CHAP) stosowany przez dostawców Internetu w połączeniach wdzwanianych.

RFC 2516 ↓ definiuje PPPoE, czyli wersję PPP, gdzie połączenie między modemem DSL lub ADSL i komputerem jest realizowane poprzez Ethernet.

Implementacje PPP

W Linuksie i innych Uniksach obsługa protokołu PPP jest możliwa dzięki demonowi pppd.

Zobacz też

Przypisy

  1. ↑ a b c d e Ben Smith. From Here to There. „BYTE”. Vol. 19, No. 6, s. 271-272, czerwiec 1994. (ang.). 

Linki zewnętrzne

  • W. Simpson, The Point-to-Point Protocol (PPP), STD 51, RFC 1661, IETF, lipiec 1994, DOI: 10.17487/RFC1661, ISSN 2070-1721, OCLC 943595667 (ang.).
  • W. Simpson, PPP Challenge Handshake Authentication Protocol (CHAP), RFC 1994, IETF, sierpień 1996, DOI: 10.17487/RFC1994, ISSN 2070-1721, OCLC 943595667 (ang.).
  • L. Mamakos i inni, A Method for Transmitting PPP Over Ethernet (PPPoE), RFC 2516, IETF, luty 1999, DOI: 10.17487/RFC2516, ISSN 2070-1721, OCLC 943595667 (ang.).
ℹ Źródło: artykuł „Point-to-Point Protocol” w polskiej Wikipedii. Treść dostępna na licencji CC BY-SA 4.0; lista autorów w historii edycji. Wersja może się różnić od aktualnej na Wikipedii (kopia odświeżana okresowo).
💳 Revolut
Karta wielowalutowa do podróży — płacisz za granicą bez przewalutowań.
Odbierz kartę →
💰 ZEN.COM
Konta multiwalutowe i karty — płatności bez granic z poziomu aplikacji.
Sprawdź ZEN →
🌍 Wise
Przelewy za granicę po realnym kursie — bez ukrytych marż.
Wypróbuj Wise →
Linki polecające — obowiązują regulaminy usług.
FazaFM.com — radio i newsy Hrubek.pl — Hrubieszów blisko Ciebie Gorzkie Groszki — blog